Intermittent Citrix Error - 'Unable to connect to the server'

Incident Report for WorkPac Pty Ltd

Update

Hi All,
Our team are still investigating this issue that occurs intermittently for some users.
If you experience this issue - please close the error & re-click the Citrix application you're trying to open to reconnect again, as access is generally established after a couple of attempts.
Thanks teams.
Posted Nov 07, 2025 - 13:37 AEST

Update

Hi All,
Our team is continuing to investigate this matter in order to determine the root cause.
If you experience this issue today, please inform your BAM who will log a request on your behalf. This will assist us in understanding the scope of the impact and the frequency of occurrence.
Thank you for your cooperation
Posted Sep 09, 2025 - 10:48 AEST

Investigating

We are aware that some users may encounter an intermittent error when accessing applications within Citrix. The error message may read:
"Unable to connect to the server. Contact your system administrator with the following error: The Citrix SSL server you have selected is not accepting connections."

Our team is actively investigating the root cause.
In the interim, if you experience this issue - please close the page, reopen & attempt to reconnect again as access is generally established after a couple of attempts.
We will provide an update as soon as more information becomes available.
Posted Sep 08, 2025 - 12:10 AEST
This incident affects: Citrix.